Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 34278 Accepted: 14706
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 34278 Accepted: 14706
Description
You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogdaycat atcay
pig igpay
froot ootfray
loops oopslay
atcay
ittenkay
oopslay
Sample Output
cateh
loops
Hint
Huge input and output,scanf and printf are recommended.Source
Waterloo local 2001.09.22
题目大意:给出字符串的对应关系,输入第二个求对应的第一个,不存在输出eh
题目分析:字典树或者map,题意很裸,建立相应的对应关系即可,map的话2000ms+过,字典树700ms+
Trie树:
#include <cstdio>
#include <cstring>
struct Dic
{
char s1[15], s2[15];
int id;
}d[100005];
struct node
{
node *next[26];
bool end;
int id;
node()
{
memset(next, NULL, sizeof(next));
end = false;
id = -1;
}
};
void Insert(node *p, char *s, int id)
{
for(int i = 0; s[i] != '\0'; i++)
{
int idx = s[i] - 'a';
if(p -> next[idx] == NULL)
p -> next[idx] = new node();
p = p -> next[idx];
}
p -> end = true;
p -> id = id;
}
int Search(node *p, char *s)
{
for(int i = 0; s[i] != '\0'; i++)
{
int idx = s[i] - 'a';
if(p -> next[idx] == NULL)
return -1;
p = p -> next[idx];
}
if(p -> end)
return p -> id;
return -1;
}
int main()
{
char s[30], get[15];
int cnt = 0;
node *root = new node();
while(gets(s) && strlen(s))
{
d[cnt].id = cnt;
sscanf(s, "%s %s", d[cnt].s1, d[cnt].s2);
Insert(root, d[cnt].s2, cnt);
cnt++;
}
while(scanf("%s", get) != EOF)
{
int id = Search(root, get);
if(id == -1)
printf("eh\n");
else
printf("%s\n", d[id].s1);
}
}
map:
#include <iostream>
#include <map>
#include <cstring>
#include <string>
#include <cstdio>
using namespace std;
char s[30], s1[15], s2[15];
string s3, tmp;
map <string, string> mp;
map <string, string> :: iterator it;
int main()
{
while(gets(s) && strlen(s))
{
sscanf(s, "%s %s", s1, s2);
mp[s2] = s1;
}
while(cin >> s3)
{
it = mp.find(s3);
if(it == mp.end())
cout << "eh" << endl;
else
cout << it -> second << endl;
}
}